戦闘画面のアニメーションの位置について

ひさこ

ユーザー
初めまして、少しお伺いしたいことがあり、質問しました。
プラグインAtelier Rgss様(https://atelierrgss.wordpress.com/)のテンプレートの中にある
11_Planetarianという battle hudを使用しています。
ここで問題なのですが、フロントビューにした時になぜか(アニメーション表示を画面に設定したときだけ)アニメーションの表示が左上に表示されて
しまいます。試行錯誤してみたのですが、自分ではどうすることもできませんでした。
よろしければご教授お願いいたします!
 
最後に編集:

munokura

ユーザー
質問の意味が分かりません。
で、プラグインを翻訳してみました。

日本語版 MOG Battle Hud プラグインVer5.04
https://fungamemake.com/archives/2250

すると、確認すべき点が分かってきました。
アニメーションとはどのアニメーションを指していますか?
このプラグインで設定できるアニメーションは多数あり、どのアニメーションなのか分かりません。
他のプラグインをOFFにした状態で同じことが起こるのか試していますか?
試行錯誤した内容を書かれていないと、こちらが提示しても「それは試しました」と言われるのはモチベーションが下がります。
このプラグインのテンプレートセットは、プラグインのデフォルト数値が画像に合わせて設定されているだけで、プラグインそのものは同じものです。
また、今回の11番のセットは、サンプルプロジェクトで採用しているデフォルトです。
ですので、MOG Battle Hud プラグインの設定の問題の可能性は低いと思います。
 
最後に編集:

munokura

ユーザー
ひさこ様
多分以下の1ページ目にある情報と同じだと思います。
https://forum.tkool.jp/index.php?threads/プラグインの使い方が分からない向けのq-a.468/
https://tm.lucky-duet.com/viewtopic.php?f=23&t=4173&p=14856&hilit=battlehud#p14856
のパッチプラグインで解決できるという意味でしょうか?

つまり、MOG Battle Hud プラグインにバグがあるということですよね?
これは製作者にはどうお伝えしたら、上手く伝わるでしょうか?
 

まっつUP

ユーザー
現行のmog系のバージョンではどうなのか確認していませんが
単にフロントビューで味方側対象の画面アニメーションが表示される位置が適切でないとしか言いようがないですね。
 

munokura

ユーザー
現行のmog系のバージョンではどうなのか確認していませんが
単にフロントビューで味方側対象の画面アニメーションが表示される位置が適切でないとしか言いようがないですね。
今は5.04となっていますが、履歴が下記しか無いので、このバグは直っていないと思います。

* - (version 5.04)
* (BUG FIX) - 前回の戦闘でキャラクターが殺された場合、
* 戦闘開始時に正しい顔を表示しない現象を修正。

また、まっつUP様のプラグインに触れている方々も、このプラグインにしか触れていませんし…。
ちなみに、このパッチが対応するのは
  1. 戦闘中のアクターのスキルのアニメーション
  2. 戦闘中の敵のスキルのアニメーション
の両方ですか?
 

まっつUP

ユーザー
特に行動主体(使用者)の区別はしていませんね。
あの拙作のプラグイン自体は、応急処置的なものなので完全に不満にならない状態に改善するとは限りません。
もちろん問題が解消できればそれでよいと思っています。
 

munokura

ユーザー
動作確認しました。

環境
コアスクリプト Ver1.6.2
MOG Battle Hud プラグインVer5.04
でフロントビュー及びサイドビューでの戦闘で、スキルのアニメーション位置の問題は発生しませんでした。
これはまっつUP様のパッチプラグイン(ForcemogFocus.js)を入れていない状態です。
これらより、下記が原因と予想いたします。
  1. MOG Battle Hud プラグイン のバージョンが古い
  2. 他のプラグインとの競合
  3. 他のプラグインのバグか設定ミス
参考になれば幸いです。
 

ひさこ

ユーザー
この度はお忙しい中、ご返信をいただき、誠にありがとうございます。
自身の多忙により、ご返信が遅くなりましたこと、その上、始めてツクールフォーラムを利用したので、知識が浅いまま、分かりずらい質問をしてしまい、まことに申し訳ございませんでした。
munokura様、まっつUP様のご指摘いただいた通りに二通り試したところ、どちらもフロントビューにてアニメーションの位置が正常になりました!本当にありがとうございます!お忙しい中、お手間を取らせてしまって本当に申し訳ありませんでした。
 
最後に編集:
トップ