androidと1.5.0

てんほう

ユーザー
ツクールmv1.3.5で新規作成したプロジェクトから生成したapkはandroidで動作しますが、ツクールmv1.5.0で新規作成したプロジェクトから生成したapkはandroidで動作しません。
androidで起動すると「undefined is not a function」と表示されます。
apkの作成はツクールmvのヘルプの通りにしています。
Googleで検索したら海外のフォーラムで同じエラーを見つけましたが、解決していないようです。
https://forums.rpgmakerweb.com/inde...r-for-android-deployment-in-rmmv-1-5-0.80359/
誰か情報を持っているかたはいますか?
 

剣崎宗二

ユーザー
リンク先を見る限り、pixi.jsのバージョンアップに関連する問題のようです。
該当のフォーラムでは「プラグインフォルダ内を全て旧バージョンに置き換えたら直った」と言っています。
 

てんほう

ユーザー
リンク先の説明だとindexファイルとjsファイルを1.3.4のものに置き換えたら動いたと言っているように見えます。
それだと単に1.3.4で動作していることになります。
1.3.5で動作することは私も確認済みなので、1.5.0で動作させる方法があれば知りたいです。
1.5.0だと高速化するらしいので期待しているのですが、方法がなければしかたありません。
ちなみにiOSだと1.5.0で作成したipaファイルは動作します。
 

剣崎宗二

ユーザー
該当フォーラムの先を辿っていくと、その1.5.0で高速化された「pixi.js」が問題であるかも知れないと指摘している方が居ます。
その場合は高速化の処理がそのままバグの原因になっているので、公式にそのバグを直してもらう以外は難しいかと…
 
トップ